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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates the procedure has
only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown (e.g., “copy
file1 ” means type the word copy, then type a space, then type file1).

o On-screen prompts and messages, names of options and text fields, and menu
commands. Menu commands are often separated by greater than signs (>) (e.g.,
“Click HFSS > Excitations > Assign >Wave Port).

o Labeled keys from the computer keyboard. For example, “Press Enter ” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics (e.g., “copyfile name” means type the word copy, then type a space, then
type the name of the file).

l The plus sign (+) is used between keyboard keys to indicate that both keys should be
pressed at the same time (e.g., “Press Shift +F1 ” means to press Shift and, while holding
it down, press F1). Always depress the modifier key or keys first (e.g., Shift, Ctrl, Alt, or
Ctrl +Shift), continue to hold it/them down, then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Layout > Interface Ground "
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This instruction means click the Interface Ground command from the Layout tab. An
image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"From the Filemenu, selectOpen Examples" means click the Filemenu and select
Open Examples from the drop-down menu.

l Another alternative is to right-click and select from the shortcut menu. An example of a
typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means select an object, right-
click, and click an option from the shortcut menu that appears.

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. This information can also be obtained by contacting an Ansys
account manager.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps are taken
or what stages the simulation reached, including software files as applicable. This allows more
rapid and effective debugging.

Help Menu

From the Help menu, select Help and choose from the following:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1 to open the selected help for the active product.

Press F1 while the cursor is pointing at a menu command or while a particular window tab is
open. In this case, the help page associated with the command or open window is displayed
automatically.
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1 - Introduction
Complete theGetting Started with HFSS 3D Layout: Microstrip Filter guide to create, solve,
and analyze a microstrip bandstop filter using the HFSS 3D Layout design type in the
Electronics Desktop application. A bandstop filter (i.e., a band-rejection filter) is a device that
attenuates signals within a target frequency band while passing higher and lower frequencies
unaltered. It is the opposite of a bandpass filter.

Note:

The following screenshot was taken with HFSS 3D Layout > HFSS Extents enabled.
The outer envelope represents the boundary of the default air box surrounding the
model, which is the extent of the solution region meshed and solved when an HFSS
analysis is performed.

Getting Started with HFSS™ 3D Layout: Microstrip Filter
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Getting Started with HFSS™ 3D Layout: Microstrip Filter

Note:

In theGetting Started with HFSS 3D Layout Low Pass Filter guide, the ground plane
layer of the stackup was defined as Negative, and any objects drawn on that layer
represented areas of removed conductor. In this exercise, the ground layer is
notNegative.

Draw the model using parametric design variables for the signal layer. Then evaluate and
compare the filter response using an HFSS analysis.

Setting General Options
Before inserting an HFSS 3D Layout Design into the project, follow these steps to ensure the
default unit of length measurement is set tomil.

1. From the Desktop ribbon tab, clickGeneral Options.
2. In the tree on the left side of theOptions window, expand theGeneral group and select

the Default Units subgroup.
3. Selectmil from the Length drop-down menu.
4. ClickOK to close theOptions window.

Create the Model
From here, continue to the following topics to define the stackup layers (i.e., topology) of the
model, draw the geometry of the filter, and assign the excitation ports.

l Insert Layers
l Draw the Model Geometry
l Assign the Ports
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Note:

The following figure is a diagram of the Trace (i.e., signal) layer of the microstrip
bandstop filter model.

,

There is also a 150 x 50 mil rectangular ground plane conductor drawn on a separate
layer.

Inserting Layers
Follow these steps to insert layers in an HFSS 3D Layout design.

1. From the Layout tab, click Layers dialog to open the Edit Layers window.

2. In the Edit Layers window > Stackup area, selectOverlapping from the Type drop-
down menu.

Introduction 1-3
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Add a Ground Layer to the Layer Table

Note:

When adding the first layer to the layers table, the actions of Insert above and Insert
below are identical. Once there are one or more layers, select one, then choose the
applicable option to add a new layer above or below.

1. Click Layer and select either Insert above or Insert below to open the Add Stackup
Layer window.

2. In the Add Stackup Layer window, do the following:
a. EnterGND in the Name field.
b. ClickOK to close the Add Stackup Layer window add the new ground layer to the

layer table.

Note:

The material copper is automatically assigned to signal layers.

Introduction 1-4
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Add a Dielectric Layer to the Layer Table

1. Right-click anywhere in theGND layer and select Insert dielectric above. A new row
appears in the layer table (default Name, Dielectric).

2. In the new dielectric row, do the following:
a. In the Name field, replace dielectric with Sub1.
b. Ensure 5mil is entered in the Thickness field.
c. Select Edit from theMaterial drop-down menu to open the Select Definition
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window.

3. From the Select Definition window, do the following:
a. Click Add Material to open the View / Edit Material window.
b. In theMaterial Name field, replaceMaterial1 withMy_Alumina.
c. In the Relative Permittivity Value field, replace 1 with 9.9.
d. ClickOK to save changes, close the View / Edit Material window, and return to the

Select Definition window.
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e. ClickOK to close the Select Definition window.

Add a Trace (Signal) Layer to the Layer Table

1. Right-click the Sub1 layer and select Insert signal above. A new row appears in the
table.
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2. In the new signal row, replace Signal in the Name field with Trace.

Make Changes to All Layers

1. While the Trace layer is still selected, hold Ctrl and click the first field in theGND row.
Both layers should be highlighted (i.e., selected).

2. From the Edit selected area, select Edit from theMaterial drop-down menu to open the
Select Definition window.
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3. Select pec (perfect electrical conductor) from the list of library materials. Then clickOK to
close the Select Definition window.

4. From the Layer area, re-select Select All from the drop-down menu to highlight all three
rows.
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5. Ensure the "shading" box in the Attributes area (i.e., the middle box) is checked. This
ensures that all objects will be shaded, rather than only outlined (i.e., in wire frame).

6. The Edit Layers window should now match the following example.

Note:

If the stackup is not arranged in the correct hierarchy, rearrange the layers by
clicking+dragging the selection handles in the left column. The t1 layer should
be at the top of the list, followed by the d1 layer in the middle, and the g1 layer at
the bottom.

7. Click Apply and Close to apply the layer definitions and close the Edit Layers window.
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Continue to Drawing the Ground Plane.

Drawing the Ground Plane
Follow these steps to draw a ground plane in the Layout Editor.

1. From the Layout tab, selectGND from the Active Layer drop-down menu.

2. From the Layout tab, click Draw rectangle.

Note:

Coordinates entered via the coordinate fields specify opposite corners of a rectangle.
Alternatively, entering the Center,Width, and Height of the proposed model in the
Properties window determines the dimensions of the model dependent from the
rectangle's centroid.

3. Do not click+drag in the Layout Editor. Instead, move the cursor to the X coordinate
field at the bottom of the Layout Editor. Click inside the field, delete the coordinates
already present, and enter 50.

4. Press Tab to move the cursor to the Y coordinate field. Then type 0 in the field and press
Enter.
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5. Press Tab until the cursor moves to the Delta X coordinate field. Then type 150 in the
field.

6. Press Tab to move the cursor to the Delta Y coordinate field. Then type 50 in the field.

7. Press Enter to complete the ground plane.

8. With the new ground plane selected, ensure the 2 pt Description option in the
Properties window is not selected.

9. Enter 50 ,0 in the Center field and press Enter or Tab to relocate the ground plane,
centered at 50, 0.
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10. Press Ctrl+D to fit the drawing in the Layout Editor and clear the current selection.

Continue to Creating L1.

Creating L1
Follow these steps to create the object L1 and then parameterize the object. When an object is
parameterized, variables are defined for the coordinates and dimensions rather than absolute
numeric values. In this way, define additional objects based on parameters of previously defined
ones, to quickly alter the geometry of the model by editing the design parameters. All geometry
directly or indirectly based on an altered parameter is automatically updated.
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1. From the Layout tab, select Trace from the Active Layer drop-down menu.

2. From the Layout tab, click Draw rectangle.
3. Do not click+drag in the Layout Editor. Instead, move the cursor to the X coordinate

field at the bottom of the Layout Editor. Click inside the field, delete the coordinates
already present, and enter 0.

4. Press Tab to move the cursor to the Y coordinate field. Then type 0 in the field and press
Enter.

5. Press Tab until the cursor moves to the Delta X coordinate field. Then type 96 in the field.
6. Press Tab to move the cursor to the Delta Y coordinate field. Then type 4.8 in the field.
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7. Press Enter to complete L1.

8. Select L1 to populate the Properties window. Then make the following changes:

a. Ensure the 2 pt Description option is not selected.
b. Enter L1 in theWidth field. Then press Enter or Tab to open the Add Variable

window.
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c. Ensuremil is selected from the Unit drop-down menu and 96 is entered in the
Value field. Then clickOK to close the Add Variable window.
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d. EnterW in the Height field. Then press Enter or Tab to open the Add Variable
window.
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e. Ensuremil is selected from the Unit drop-down menu and 4.8 is entered in the
Value field. Then clickOK to close the Add Variable window.

f. Enter L1/2, W/2 in the Center field and press Enter or Tab to accept the
coordinates
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Continue to Creating Stub 1.

Creating Stub 1
Follow these steps to create the object Stub 1 and then parameterize the object.
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1. From the Layout tab, click Draw rectangle.
2. Click the lower-left corner of L1 (i.e., 0, 0).

Note:

The cursor changes from a rectangle to a square when a snapping point is
detected.

3. Press Tab until the cursor moves to the Delta X coordinate field. Then type 4.8 in the field.
4. Press Tab to move the cursor to the Delta Y coordinate field. Then type -4.8 in the field.
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5. Press Enter to complete Stub 1.

6. Select Stub 1 to populate the Properties window. Then make the following changes: 
a. Ensure the 2 pt Description option is not selected.
b. EnterW in theWidth field. Then press Enter or Tab.
c. Enter S in the Height field. Then press Enter or Tab to open the Add Variable

window.
d. Ensuremil is selected from the Unit drop-down menu and 4.8 is entered in the

Value field. Then clickOK to close the Add Variable window.
e. EnterW/2, -S/2 in the Center field and press Enter or Tab to accept the
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coordinates.

Continue to Creating L2.

Creating L2
Follow these steps to create the object L2 and then parameterize the object.

1. From the Layout tab, click Draw rectangle.
2. Click the lower-left corner of Stub 1 (i.e., 0, -4.8).
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3. Press Tab until the cursor moves to the Delta X coordinate field. Then type 86.4 in the
field.

4. Press Tab to move the cursor to the Delta Y coordinate field. Then type -4.8 in the field.
5. Press Enter to complete L2.

6. Select L2 to populate the Properties window. Then make the following changes:
a. Ensure the 2 pt Description option is not selected.
b. Enter L2 in theWidth field. Then press Enter or Tab to open the Add Variable

window.
c. Ensuremil is selected from the Unit drop-down menu and 86.4 is entered in the

Value field. Then clickOK to close the Add Variable window.
d. EnterW in the Height field. Then press Enter or Tab.
e. Enter L2/2, -S-W/2 in the Center field and press Enter or Tab to accept the
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coordinates.

Continue to Creating Stub 2.

Creating Stub 2
Follow these steps to create the object Stub 2 and then parameterize the object.

1. From the Layout tab, click Draw rectangle.
2. Click the upper-right corner of L1 (i.e., 96, 4.8).
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3. Press Tab until the cursor moves to the Delta X coordinate field. Then type -4.8 in the
field.

4. Press Tab to move the cursor to the Delta Y coordinate field. Then type 4.8 in the field.
5. Press Enter to complete Stub 2.

6. Select Stub 2 to populate the Properties window. Then make the following changes: 
a. Ensure the 2 pt Description option is not selected.
b. EnterW in theWidth field. Then press Enter or Tab.
c. Enter S in the Height field. Then press Enter or Tab.
d. Enter L1-W/2 , W+S/2 in the Center field and press Enter or Tab to accept the
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coordinates.

Continue to Creating L3.

Creating L3
Follow these steps to create the object L3 and then parameterize the object.

1. From the Layout tab, click Draw rectangle.
2. Click the upper-right corner of Stub 2 (i.e., 96, 9.6).
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3. Press Tab until the cursor moves to the Delta X coordinate field. Then type -86.4 in the
field.

4. Press Tab to move the cursor to the Delta Y coordinate field. Then type 4.8 in the field.
5. Press Enter to complete L3.

6. Select L3 to populate the Properties window. Then make the following changes: 
a. Ensure the 2 pt Description option is not selected.
b. Enter L2 in theWidth field. Then press Enter or Tab.
c. EnterW in the Height field. Then press Enter or Tab.
d. Enter L1-L2/2, W+S+W/2 in the Center field and press Enter or Tab to accept the
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coordinates.

Continue to Creating Input 1.

Creating Input 1
Follow these steps to create the object Input 1 and then parameterize the object.

1. From the Layout tab, click Draw rectangle.
2. Click the lower-left corner of L1 (i.e., 0, 0).
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3. Press Tab until the cursor moves to the Delta X coordinate field. Then type -14.4 in the
field.

4. Press Tab to move the cursor to the Delta Y coordinate field. Then type 4.8 in the field.
5. Press Enter to complete Input 1.

6. Select Input 1 to populate the Properties window. Then make the following changes: 
a. Ensure the 2 pt Description option is not selected.
b. Enter L2 in theWidth field. Then press Enteror Tab to open the Add Variable

window.
c. Ensuremil is selected from the Unit drop-down menu and 14.48 is entered in the

Value field. Then clickOK to close the Add Variable window.
d. EnterW in the Height field. Then press Enter or Tab.
e. Enter -Li/2, W/2 in the Center field and press Enter or Tab to accept the
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coordinates.

Continue to Creating Input 2.

Creating Input 2
Follow these steps to create the object Input 2 and then parameterize the object.
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1. From the Layout tab, click Draw rectangle.
2. Click the lower-right corner of L1 (i.e., 96, 0).
3. Press Tab until the cursor moves to the Delta X coordinate field. Then type 14.4 in the

field.
4. Press Tab to move the cursor to the Delta Y coordinate field. Then type 4.8 in the field.
5. Press Enter to complete Input 2.

6. Select Input 2 to populate the Properties window. Then make the following changes: 
a. Ensure the 2 pt Description option is not selected.
b. Enter Li in theWidth field. Then press Enteror Tab.
c. EnterW in the Height field. Then press Enter or Tab.
d. Enter L1+Li/2, W/2 in the Center field and press Enter or Tab to accept the
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coordinates.

Continue to Creating Edge Ports.

Creating Edge Ports
Follow these steps to add two edge ports to the model.

1. To create the first port (i.e., Port1), first press E to immediately enter Select Edgesmode.

Note: Once Select Edges is selected, the cursor changes: a diagonal line
crosses the tip of the arrow.
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2. Click the left edge of Input 1 to select it.

3. From the Layout tab, select Create edge port.
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Note:

Once a port is created, it appears in the Project Manager > Project Tree >
[active design folder] > Excitations folder.

4. Repeat steps 1-3 to create the second port (i.e., Port2) on the right edge of Input 2.
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Note:

In the Low Pass Filter Getting Started Guide, the individual objects comprising the
trace layer were united into a single object. However, because this model is
parametric, do not unite the objects. Unlike the 3D Modeler used for conventional
HFSS designs, the Layout Editor does not maintain the full parametric history of the
model construction. If the trace objects are united, the parameters defined for the
individual rectangles no longer have any effect on the geometry. Once the individual
rectangles are merged into a complex polygon, the vertices of that polygon are defined
using their absolute numerical coordinates. Therefore, altering the design variables no
longer has an effect on the model because the variables are no longer used to define
the united object. All of the edges of the conducting objects in this exercise are
coincident with their adjacent objects' edges. Whether united or not, the trace objects
behave like a single conducting part and the solver treats the objects as a contiguous
conducting part.

Continue to Setting Port Excitations.

Setting Port Excitations
In order to create meaningful results with the microstrip filter design, one edge port should act as
the filter input and the other as the filter output. By default, a 1 volt excitation at 0 degrees phase
is applied to each edge port (i.e., Port1 and Port2). Follow these steps to modify the port
excitations to specify 0 volts at Port2, allowing it to act as the filter output.
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1. From HFSS 3D Layout, select Port Excitations to open the Port Excitations window.
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2. From the Port Excitations window, enter 0V in the Port2 Magnitude field.

3. ClickOK to close the Port Excitations window and return to the Layout Editor.
4. Save the project, either by navigating to File > Save or clicking the Save button on any of

the ribbons.

Continue to Creating an HFSS Analysis Setup.
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2 - Analysis and Post-Processing
This chapter contains the following topics:

l Create HFSS Analysis Setup
l HFSS Bounding Box
l Validate and Analyze
l Review HFSS Convergence Data
l Plotting the HFSSMesh
l Create Comparative S-Parameter Plot
l Add and Analyze a Discrete Sweep
l Create and Animate a Current Overlay
l Create and Animate an E Field Overlay

Creating an HFSS Analysis Setup
Solution setups are listed in the Project Manager window (i.e., expand the Project Tree >
[active design folder] > Analysis). Follow these steps to add an HFSS Analysis setup
solution to this project using basic, initial meshing tools.

1. From the Simulation ribbon tab, navigate to HFSS > Advanced to open the Setup
window.
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2. Enter 20 in the Frequency field.
3. From the Fields area, check the Save fields box.

4. Navigate to theOptions tab.
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5. EnsureMixed Order is selected from theOrder of Basis Functions drop-down menu.
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6. ClickOK to close the Setup window and open the Edit Frequency Sweep window.

7. Ensure Interpolating is selected from the Sweep Type drop-down menu and Linear
Step is selected from the Distribution drop-down menu.

8. Enter the following parameters in the first row of the Frequency Sweeps table:
l 4 (GHz) in the Start field.
l 20 (GHz) in the End field.
l 0.02 (GHz) in the Step size field.
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9. ClickOK to add the interpolating sweep and close the Edit Frequency Sweep window.

Continue to Displaying the HFSS Bounding Box.

Displaying the HFSS Bounding Box
Follow these steps to display and then hide a bounding box around the complete design in the
Layout Editor.

1. From HFSS 3D Layout, select HFSS Extents to open the Set HFSS Model Extents
window.
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2. Ensure theOpen Region box is checked and Radiation is selected.
3. From the Dialectric area, enter 0 in the Horizontal Padding field.
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4. Click Apply to save changes.
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5. ClickOK to close the Set HFSS Model Extents window.
6. Navigate to the View ribbon.

7. Click HFSS Extents to display a bounding box around the design in the Layout Editor.

8. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor
controls.
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9. Repeat step 7 to hide the bounding box.

Continue to Validating and Analyzing the Design.

Validating and Analyzing the Design
Follow these steps to validate the active design and analyze the HFSS setup.

1. From the Simulation ribbon tab, click Validate to open the Validation Check window.

Assuming the design is valid, the Validation Check window will display the following
result.
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2. Click Close.

Note:

If the validation check detects any errors or warnings, view detailed feedback in
theMessage Manager window.

3. To sequentially run all analysis setups and associated frequency sweeps in the active
design, navigate to the Project Manager window, right-click Analysis, and select
Analyze.
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Note:

Alternatively, run a single setup or sweep by right-clicking the applicable setup or
sweep and select Analyze.

Continue to Viewing Convergence History.

Viewing Convergence History
Follow these steps to view the active design's analysis convergence history.

1. From the Project Manager window, expand Analysis. Then right-click Setup1 and select
Convergence to open the Solutions window.
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2. Select View: Plot.

3. Click Close.

Continue to Plotting the HFSS Mesh.

Plotting the HFSS Mesh
Follow these steps to plot and view a mesh of the HFSS Setup solution.

1. From the Project Manager window, right-click Field Overlays and select Plot Mesh to
open the Create Mesh Plot window.
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2. Under the Nets and Layers tab, check the Trace and Sub1 boxes to only plot the mesh
on those layers.
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3. Click Done to close the Create Mesh Plot window and display the mesh for the Setup1 :
Last Adaptive solution in the Layout Editor.

Note:

To change a mesh, from the Project Manager window, expand Field Overlays
> MeshPlots. Then right-click the mesh (e.g.,Mesh1) and select Reassign.

4. From the Project Manager window, expand Field Overlays. Then right-clickMeshPlots
and selectModify Attributes to open theMeshPlots window.
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5. Either click+drag the Transparency scale marker or enter 60 in the field to improve the
visibility of the mesh lines (i.e., element edges).
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6. Click Apply.
7. Click Close to return to the Layout Editor.
8. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor

controls.
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9. From the Project Manager window, right-click the mesh (e.g.,Mesh1) and select Plot
Visibility to remove the adjacent check mark and hide the mesh.
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Continue to Creating the S-Parameter Plot.

Creating the S-Parameter Plot
Follow these steps to create an S-Parameter plot with two traces, two each, then compare the
result of the solution types.
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1. From the Results ribbon tab, select Standard Report > 2D to open the Report window.

2. From the Report window, ensure the following settings are selected:
l From the Solution drop-down menu, Setup1 : Sweep1.
l From the Domain drop-down menu, Sweep.
l From the Category list, S Parameter.
l From the Function list, dB.
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3. From theQuantity list, Ctrl+click to select S(Port1,Port1) and S(Port1,Port2).

4. Click New Report and the return loss plot opens under the Report window.
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5. Close the Report window to view the plot.
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6. Right-click within the report window and select Add Note to open the Add Note window.

7. Enter HFSS Results Comparison in the Add Note field.
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8. ClickOK to close the Add Note window and add the note to the plot.

9. Drag the note to a more desirable location. The legend can also be relocated, as
necessary.
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Note:

Both solutions demonstrate the bandstop behavior over the range of about 10 to 17
GHz. The only significant difference is in the magnitude of the three minimal points
along the traces (at 8.75, 12.5, and 15.2 GHz).

Continue to Adding and Analyzing a Discrete Sweep.

Adding and Analyzing a Discrete Sweep
In HFSS 3D Layout designs, surface current results are only available for the last pass of an
adaptive mesh or for discrete sweeps. Before viewing surface current results from the
conducting layers, follow these steps to define a discrete sweep with results at two frequencies:
one at a low pass-through frequency and one in the middle of the bandstop range.
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1. From the Project Manager window, right-click Setup1 and select Add Frequency
Sweep to open the Add Frequency Sweep window.
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2. From the Edit Frequency Sweep window, do the following:
l Select Discrete from the Sweep Type drop-down menu.
l Select Single Point from the Distribution drop-down menu.
l From the Frequency Sweeps table, enter 4 (GHz) in the Start column.
l Click Add Below.
l In the new row, enter 14 (GHz) in the Start column.
l From theOptions area, check the Save fields box.

3. ClickOK to add the discrete sweep and close the Edit Frequency Sweep window.

Analysis and Post-Processing 2-28

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™ 3D Layout: Microstrip Filter

4. From the Project Manager window, expand Setup1 and right-click Sweep2. Then select
Analyze.

Continue to Creating and Animating the Current Overlay.

Creating and Animating the Current Overlay
Follow these steps to create and animate the current overlay.
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1. Return to the design by navigating toWindow > Layout.

2. From the Project Manager window, right-click Field Overlays and select Plot Fields > J
> Mag_Jsurf to open the Create Field Plot window.
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3. From the Create Field Plot window, do the following:
l Select Setup1 : Sweep2 from the Solution drop-down menu.
l Ensure 4Ghz is selected from the Freq (i.e., frequency) drop-down menu andMag_Jsurf
is selected from theQuantity list.
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l Under the Nets and Layers tab, check the Trace andGND boxes.
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4. Click Done to save changes, close the Create Field Plot window, and view the overlay.

5. From the Layout tab, double-click in the current plot overlay legend to open the (Jsurf)
plot settings window.
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6. Select the Scale tab and do the following:
a. Enter 10 in the Num. Division field.
b. Select Log to produce a logarithmic scale.
c. Select Automatic from the Type drop-down menu.
d. Enter 2 in the Precision field.
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e. Click Apply to save changes.

7. Close the plot settings window.
8. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor

controls.
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9. From the Project Manager window, expand Jsurf. Then right-clickMag_Jsurf1 and
selectModify Plot to open theModify Field Plot window.
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10. From theModify Field Plot, do the following:

l Select 14GHz from the Freq drop-down menu in the Intrinsic Variables area.

l Click Apply.
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11. Click Done to close the window and return to the Layout Editor.

12. From the Project Manager window, right-clickMag_Jsurf1 and select Animate to open
the Create Animation Setup window.
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13. From the Create Animation Setup window, ensure the following settings were selected
by default:

l Single variable and Phase are selected from the drop-down menus.

l 0deg is entered in the Start field.

l 170deg is entered in the Stop field.
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l 17 is entered in the Steps field.

14. ClickOK to close the Create Animation Setup window and open the Selection
Animation window. The only available option (i.e., Animation1) is selected by default.

Analysis and Post-Processing 2-41

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™ 3D Layout: Microstrip Filter

15. Click Animate to close the Select Animation window, open an animation control panel,
and start the animation in the Layout Editor.
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Note:

The current at Port 2 remains relatively low throughout the animation. This is
expected.

16. Use the animation controls to reverse, stop, and change the speed of the animation,
among other settings.

17. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor
controls.

18. From the animation control panel, click Close to end the animation.
19. Before continuing, navigate to the Project Manager window. Then right-clickMag_

Jsurf1 and select Plot Visibility to remove the adjacent check mark and hide the overlay.
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Continue to Creating and Animating an E Field Overlay.
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